Get in touch
Back
Maintenance

Undergoing Maintenance

Completed 26 Jan at 09:30am PST.

app.fundwriter.ai
Completed

Maintenance completed

Posted 26 Jan at 09:30am PST.
Started

The app is up and functioning properly again.

Posted 26 Jan at 09:15am PST.